Release 2.14
[debian/dhcpd-pools.git] / configure.ac
index 94bd968..049073e 100644 (file)
@@ -1,16 +1,23 @@
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 
-AC_PREREQ(2.63)
-AC_INIT([dhcpd-pools],[2.13],[kerolasa@iki.fi],,[http://dhcpd-pools.sourceforge.net/])
-AM_INIT_AUTOMAKE(dhcpd-pools, 2.13)
+AC_PREREQ(2.64)
+AC_CONFIG_MACRO_DIR([m4])
+AC_INIT([dhcpd-pools],[2.14],[kerolasa@iki.fi],,[http://dhcpd-pools.sourceforge.net/])
+AM_INIT_AUTOMAKE
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADERS([config.h])
 
-# Checks for programs.
+AC_GNU_SOURCE
+
+# Checks for programs
 AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_MAKE_SET
+AC_PROG_LIBTOOL
 
 # Checks for libraries.
+LT_INIT
 
 # Checks for header files.
 AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h netinet/in.h stdlib.h string.h strings.h sys/socket.h unistd.h])
@@ -21,7 +28,7 @@ AC_TYPE_SIZE_T
 
 # Checks for library functions.
 AC_FUNC_MALLOC
-AC_CHECK_FUNCS([inet_ntoa memset strerror strstr])
+AC_CHECK_FUNCS([inet_ntoa memset strerror strstr strdup])
 
 # GNU commandline parsing in getopt.h present?
 AC_CHECK_HEADERS(getopt.h, AC_DEFINE(HAVE_GETOPT_H),